

Didn’t expected a “Great Teacher Onizuka” meme after all these years but yeah!
Didn’t expected a “Great Teacher Onizuka” meme after all these years but yeah!
It’s “fuselage”.
It’s called like that because of it came from the word “forme fuselé” (Tapered shape) and it’s a french word mainly because we created it in 1908.
You’re welcome :-)
Indeed, you can achieve a better result with less verbose naming convention. And choose better variable name to make it obvious than 0 Hp is death. While i don’t like having too verbose variable name (as it impacts the readability and quick understanding of the function), i’m not against that for the function name… without going too far of course!
Best is too have proper datamodeling of the object manipulated on top of some classic basic comments. Good interface contract is also a minimum. Best is to have full datamodeling of all the services, objects, in and out interactions between them, etc.
Documentation is a mandatory piece of the code delivery (with tests being the other important part) far too much forgotten if you don’t enforce it on your teams.
I don’t see the benefit of this long naming convention…
It still allow bug to exist… like the fact that, with this code, the player can still play with 0 Hp.
Should have been better to put a “if(health <= 0)” instead of “< 0”
i have pihole, will add unbound to my todo list